Dropped clicks on servers with tgui

For feedback on the game code and design. Feedback on server rules and playstyle belong in Policy Discussion.

Moderators: MisterPerson, Code Maintainers

User avatar
Mice World
 
Joined: Mon Jan 18, 2021 4:11 am
Location: Space Australia
Byond Username: Mice World

Dropped clicks on servers with tgui

Postby Mice World » Wed Jun 09, 2021 12:11 am #602365

Hello, Over the past 3 months I've been having massive issues on any server with tgui. Whenever I spam click (Combat, backpack managing etc) about half the clicks won't go through, I'll be stuck not being able to click for about 3-4 seconds then my previous clicks will all go through at once followed by the "connection lost" message. This doesn't sound that bad on paper, but it really makes the game unplayable. I can't do anything related to combat and I must backpack mange very slowly. I've lost at least four traitor rounds because of this issue.

It could be an internet issue, as I do live in Australia. However, as I said before this only seems to happen on servers with tgui. I've cleared byond's cache. I've tried both stable and beta branches of byond. I've reinstalled beyond. But nothing seems to help.

Laptop specs
Spoiler:
Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD A4-9125 RADEON R3, 4 COMPUTE CORES 2C+2G
CPU Family: 0x15
CPU Model: 0x70
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 2296 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
AVX2: Supported
AVX512F: Unsupported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Unsupported
AVX512VNNI: Unsupported
SHA: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported

Video Card:
Driver: AMD Radeon(TM) R3 Graphics
DirectX Driver Name: aticfx32.dll
Driver Version: 27.20.11044.7
DirectX Driver Version: 27.20.11044.7
Driver Date: 9 24 2020
OpenGL Version: 4.6
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon(TM) R3 Graphics
VendorID: 0x1002
DeviceID: 0x98e4
Revision: 0xe2
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1280 x 1024
Desktop Resolution: 1280 x 1024
Primary Display Size: 13.31" x 10.63" (17.01" diag) 33.8cm x 27.0cm (43.2cm diag)
Primary VRAM: 512 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (USB Audio Device)

Memory:
RAM: 7641 Mb

Miscellaneous:
UI Language: English
Media Type: Undetermined
Total Hard Disk Space Available: 953076 Mb
Largest Free Hard Disk Block: 677602 Mb
OS Install Date: Jan 01 1970
Game Controller: None detected

Storage:
Disk serial number hash: 1ae94cbe
Number of SSDs: 0
SSD sizes: %s1
Number of HDDs: 1
HDD sizes: 1000G


As ss13 is a niche game, it's hard to search for previous issues so sorry if this has already been reported. I would make a github issue report, but I the lack important information required. So I figured the forum would be my best bet.
Any and all info is appreciated. Thanks.
CoffeeDragon16/(Mythmi Aguilar) checked the individual player panel for Mice World/(Bea Socks).



User avatar
oranges
Code Maintainer
 
Joined: Tue Apr 15, 2014 9:16 pm
Location: #CHATSHITGETBANGED
Byond Username: Optimumtact
Github Username: optimumtact

Re: Dropped clicks on servers with tgui

Postby oranges » Thu Jun 10, 2021 2:44 am #602447

have you encountered this on austation?

User avatar
Mice World
 
Joined: Mon Jan 18, 2021 4:11 am
Location: Space Australia
Byond Username: Mice World

Re: Dropped clicks on servers with tgui

Postby Mice World » Thu Jun 10, 2021 7:42 am #602457

I've not yet tried austation. After trying an offline build of tgstation however, I can confirm that it isn't my internet.
CoffeeDragon16/(Mythmi Aguilar) checked the individual player panel for Mice World/(Bea Socks).

cacogen
 
Joined: Sat Jun 02, 2018 10:27 am
Byond Username: Cacogen

Re: Dropped clicks on servers with tgui

Postby cacogen » Fri Jun 11, 2021 4:39 am #602623

this is just the oceanic experience
technokek wrote:Cannot prove this so just belive me if when say this

User avatar
oranges
Code Maintainer
 
Joined: Tue Apr 15, 2014 9:16 pm
Location: #CHATSHITGETBANGED
Byond Username: Optimumtact
Github Username: optimumtact

Re: Dropped clicks on servers with tgui

Postby oranges » Sun Jun 13, 2021 9:51 pm #602877

Mice World wrote:I've not yet tried austation. After trying an offline build of tgstation however, I can confirm that it isn't my internet.

You get dropped clicks on your local?

Do you have antivirus or similar intefereing with things?

User avatar
Mice World
 
Joined: Mon Jan 18, 2021 4:11 am
Location: Space Australia
Byond Username: Mice World

Re: Dropped clicks on servers with tgui

Postby Mice World » Mon Jun 14, 2021 6:37 am #602910

The only "antivirus" I have is windows defender. It seems to be a hardware issue, maybe? After trying different pcs it only seems to happen on my laptop. I don't really understand coding, so I could be wrong. But if it isn't a hardware issue it could be an issue with tgui updating too slow? I've also noticed whenever the chat gets spammed (Like the divine retribution smite) my clicks also start getting dropped.
CoffeeDragon16/(Mythmi Aguilar) checked the individual player panel for Mice World/(Bea Socks).

User avatar
oranges
Code Maintainer
 
Joined: Tue Apr 15, 2014 9:16 pm
Location: #CHATSHITGETBANGED
Byond Username: Optimumtact
Github Username: optimumtact

Re: Dropped clicks on servers with tgui

Postby oranges » Mon Jun 14, 2021 8:44 pm #602945

it could be, updating ui elements tends to prevent the main byond thread from running, but i've never heard of it being that bad.

Is the machine underpowered such that using the web under normal circumstances results in slow stuttery browsing experiences?

User avatar
Mice World
 
Joined: Mon Jan 18, 2021 4:11 am
Location: Space Australia
Byond Username: Mice World

Re: Dropped clicks on servers with tgui

Postby Mice World » Tue Jun 15, 2021 8:19 am #603008

Watching youtube and some videos lag my laptop, but that's about it really.

I would record a video of the bug in action but right now OBS is fucked and won't work. I need a new laptop anyway, so I'll just deal with it for now.

Thanks for trying to help. If I get more info/a recording of the bug, I'll post it here.
CoffeeDragon16/(Mythmi Aguilar) checked the individual player panel for Mice World/(Bea Socks).


Return to Coding Feedback

Who is online

Users browsing this forum: No registered users