SS13 on Linux; Recent issues & Troubleshooting

General SS13 Chat
User avatar
springs eternal
 
Joined: Tue Jun 02, 2020 10:14 pm
Byond Username: Wicca Phase Springs Eternal

SS13 on Linux; Recent issues & Troubleshooting

Postby springs eternal » Fri Aug 28, 2020 11:54 pm #574235

Sup guys. Apologies if this is in the wrong area

I came back after a few months long hiatus. I use Linux, and everything works fine save for a few small quirks that didn't seem to occur before.

Basically, most of the dialog windows for vending machines/computers/control panels are broken. Some old styled ones such as the PDA still work, but most just end up like pic related. This doesn't seem to be happening on other servers (beestation, cev eris). TG is the main server I'm interested in playing on, and I've been racking my brain for a couple of days now reinstalling byond on lutris, playing with winetricks and fucking with different variables. I've totally hit a wall. Any input would be much appreciated!

Has anyone else encountered this before?

Thanks in advance.

Edit: Forgot to mention, fancy chat always fails to load and the "fix chat" button does not fix it.

Screenshot;
Spoiler:
Image
Last edited by springs eternal on Sat Aug 29, 2020 5:22 pm, edited 1 time in total.



SpaceManiac
Code Maintainer
 
Joined: Fri Sep 22, 2017 4:06 am
Byond Username: SpaceManiac
Github Username: SpaceManiac

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby SpaceManiac » Sat Aug 29, 2020 2:48 am #574249

Everything works fine on a local server and everything breaks on /tg/'s live servers for me. I'm investigating whether this has anything to do with the CDN that was recently implemented.

SpaceManiac
Code Maintainer
 
Joined: Fri Sep 22, 2017 4:06 am
Byond Username: SpaceManiac
Github Username: SpaceManiac

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby SpaceManiac » Sat Aug 29, 2020 3:34 am #574251

MrStonedOne made a configuration change to the CDN servers that resolved the problem for me. Give it another try.

User avatar
springs eternal
 
Joined: Tue Jun 02, 2020 10:14 pm
Byond Username: Wicca Phase Springs Eternal

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby springs eternal » Sat Aug 29, 2020 5:21 pm #574281

SpaceManiac wrote:MrStonedOne made a configuration change to the CDN servers that resolved the problem for me. Give it another try.

SpaceManiac wrote:Everything works fine on a local server and everything breaks on /tg/'s live servers for me. I'm investigating whether this has anything to do with the CDN that was recently implemented.



Unfortunately, still not working as of this morning. Tried both on Basil and Manuel. If I find a fix for it, I'll post it here.

Are you on linux? What distro and what version of wine?

SpaceManiac
Code Maintainer
 
Joined: Fri Sep 22, 2017 4:06 am
Byond Username: SpaceManiac
Github Username: SpaceManiac

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby SpaceManiac » Sat Aug 29, 2020 7:15 pm #574287

springs eternal wrote:Are you on linux? What distro and what version of wine?


Ubuntu 18.04.5 LTS, Wine 3.0, winetricks wsh57 mfc42 vcrun2013 ie8 allfonts, winetricks settings fontsmooth=rgb, install of gecko

User avatar
MrStonedOne
Host
 
Joined: Mon Apr 14, 2014 10:56 pm
Byond Username: MrStonedOne
Github Username: MrStonedOne

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby MrStonedOne » Sat Aug 29, 2020 8:00 pm #574290

springs eternal wrote:Sup guys. Apologies if this is in the wrong area

I came back after a few months long hiatus. I use Linux, and everything works fine save for a few small quirks that didn't seem to occur before.

Basically, most of the dialog windows for vending machines/computers/control panels are broken.


Recently we moved browser assets for in game windows (js/css/images) over to a web server (byond would normally send this to a folder hosted on a localhost server) to make in game interfaces load faster and reduce bandwidth by allowing these assets to be cached.

I'm hesitant to move the asset store to unencrypted connections over what seems to be 1 or 2 people having issues given how proliferate js http hijacking is at the internet backbone level.

The issues might be related to tls, I enabled 1.0 (the change space was talking about), but there may be a cert trust issue with your configuration.

I would start from there with your troubleshooting.

Here are some example urls to test:
Common.css: https://tgstation13.download/byond/asse ... 5de10d.css
chat output css: https://tgstation13.download/byond/asse ... f265bc.css
chat output js:
https://tgstation13.download/byond/asse ... 4f7b189.js
https://tgstation13.download/byond/asse ... b6efc5d.js
Forum/Wiki Administrator, Server host, Database King, Master Coder

MrStonedOne on Reddit(banned), Steam, IRC, Skype Discord.

Jack7D1 wrote:After reviewing the history of our previous host(s) I conclude that MSO is our most favorable host to date. To remove him would be very unwise.
Jack7D1 wrote:I seem to be mistaken

User avatar
springs eternal
 
Joined: Tue Jun 02, 2020 10:14 pm
Byond Username: Wicca Phase Springs Eternal

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby springs eternal » Sat Aug 29, 2020 8:16 pm #574292

Thanks guys, good info above.

I'll try some stuff out on my end and if I find a fix I'll post what worked for me.

Ivuchnu
 
Joined: Fri Apr 17, 2020 10:07 am
Byond Username: Ivuchnu

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Ivuchnu » Sun Aug 30, 2020 5:04 am #574317

From my experience, both TGUI and tgchat are more or less broken on IE 8. Messed with somewhat old Windows 7 install recently. As bonus, if somehow they were not, paper would be broken.

Does latest byond version work in wine? Last time I tried to get it working it crashed.
Heal w. water/starlight/rads +self-resp
Not happy with game, not happy with code.

SpaceManiac
Code Maintainer
 
Joined: Fri Sep 22, 2017 4:06 am
Byond Username: SpaceManiac
Github Username: SpaceManiac

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby SpaceManiac » Sun Aug 30, 2020 6:31 pm #574372

Ivuchnu wrote:From my experience, both TGUI and tgchat are more or less broken on IE 8. Messed with somewhat old Windows 7 install recently. As bonus, if somehow they were not, paper would be broken.

Does latest byond version work in wine? Last time I tried to get it working it crashed.

Paper is broken, but everything else works for me. System config in a previous post, BYOND 513.1528

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Mon Nov 30, 2020 12:09 am #582358

SpaceManiac wrote:
Ivuchnu wrote:From my experience, both TGUI and tgchat are more or less broken on IE 8. Messed with somewhat old Windows 7 install recently. As bonus, if somehow they were not, paper would be broken.

Does latest byond version work in wine? Last time I tried to get it working it crashed.

Paper is broken, but everything else works for me. System config in a previous post, BYOND 513.1528


Hi there,

I do have the exact same issue. It did worked several months ago, but is broken ever since.
I have white windows everywhere, like the css does not load.

@SpaceManiac, how did you make it work ?

SpaceManiac
Code Maintainer
 
Joined: Fri Sep 22, 2017 4:06 am
Byond Username: SpaceManiac
Github Username: SpaceManiac

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby SpaceManiac » Mon Nov 30, 2020 1:08 am #582360

Nibor62 wrote:It did worked several months ago, but is broken ever since.
I have white windows everywhere


Seeing the same thing on /tg/station13 servers, but it works fine locally, so presumably it's a CDN issue again, although I have no idea what exactly

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Mon Nov 30, 2020 12:01 pm #582384

Dug a little more yesterday.
It seem that https with wine ie is broken on my prefix. From what @MrStonedOne said I would guess that it may be the problem (I may miss something like crypt32 ?).
Do you have links (css & js) to check connectivity, those of @MrStonedOne seems to 404 ? If possible the ones that are needed for distributors.

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Mon Nov 30, 2020 10:42 pm #582399

I did somehow made IE8 work with https and successfully reached the @MrStonedOne links that does not 404.
Though I still have the cssless windows

User avatar
springs eternal
 
Joined: Tue Jun 02, 2020 10:14 pm
Byond Username: Wicca Phase Springs Eternal

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby springs eternal » Wed Dec 16, 2020 1:36 am #583930

Sorry about the relative necropost, but this is still an issue. I'll try and work it when I have free time, but if any other GNU/Linux aspies have input, it'd be much appreciated.

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Thu Dec 17, 2020 4:31 pm #584133

Hi,

No much more than you I am affraid.
I would still like to have links of the different resources that are dowloaded in order to see if I can download them with wine IE

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Sun Feb 07, 2021 10:46 pm #589790

Hi,

Can i make a little up there ?
I do think that this is linked to the http vs ie thing.
Could I have examples of the url that are dowloaded ?
Is there any way I could locally change https to http (in order to setup a proxy on my machine ?)

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Wed Feb 10, 2021 11:05 pm #590164

did some more tests
It seem that everything beyond tls1 is not supported by ie8 on wine.
Therefore, I tryed to setup a local https proxy in order to provide the client with a tls1 interface while my proxy would handle the higher tls with the server (alongside some caching).
It provided some result as in the main menu and character creation I had a better rendering.
However, I could not see any differences ingame (fancy chat still not loading properly and distributor still white)

BadSS13Player
 
Joined: Fri Nov 15, 2019 5:03 pm
Byond Username: BadSS13Player

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby BadSS13Player » Tue Feb 16, 2021 1:09 pm #590887

Not relevant to running SS13 in wine, but VirtualBox has fixed their Direct3D driver and it works with BYOND now (albeit with some issues when resizing the viewport where you have to close and reopen DreamSeeker). You just have to install the newest guest additions, enable 3D acceleration in VM display settings (probably also increase the allocated video memory) and use a Windows guest newer than Win7 (because VirtualBox uses a different driver on there which seems to be a lot shittier).

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Fri Feb 19, 2021 1:11 pm #591587

Actually got bored of hacking and went for a win10 over KVM. It has really good perfs which is nice.
Btw, while I was playing with KVM I eventually tried with win7 VM and got the same problem I were having with wine. I would think that in the end it is not a wine issue but an ie8 one.

BadSS13Player
 
Joined: Fri Nov 15, 2019 5:03 pm
Byond Username: BadSS13Player

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby BadSS13Player » Fri Feb 19, 2021 9:19 pm #591617

Nibor62 wrote:Actually got bored of hacking and went for a win10 over KVM. It has really good perfs which is nice.
Btw, while I was playing with KVM I eventually tried with win7 VM and got the same problem I were having with wine. I would think that in the end it is not a wine issue but an ie8 one.


Is that KVM with qemu or KVM with VirtualBox? If it's with qemu, are you using any graphics drivers? BYOND used to have an issue with win7 without graphics drivers where overlays would be invisible and that made the game unplayable. Also, you can install IE11 on win7 sp1.

Nibor62
 
Joined: Thu Aug 20, 2020 8:42 pm
Byond Username: Nibor62

Re: SS13 on Linux; Recent issues & Troubleshooting

Postby Nibor62 » Sat Feb 20, 2021 7:13 pm #591754

BadSS13Player wrote:
Nibor62 wrote:Actually got bored of hacking and went for a win10 over KVM. It has really good perfs which is nice.
Btw, while I was playing with KVM I eventually tried with win7 VM and got the same problem I were having with wine. I would think that in the end it is not a wine issue but an ie8 one.


Is that KVM with qemu or KVM with VirtualBox? If it's with qemu, are you using any graphics drivers? BYOND used to have an issue with win7 without graphics drivers where overlays would be invisible and that made the game unplayable. Also, you can install IE11 on win7 sp1.


I am using qemu/kvm with the virt-manager on arch.
I quickly went back to windows10 as I had some minor but annoying issues with win7 (the mouse was quick wierd/quircky due to the virtual touch pad not correctly handled).
Also there is a free win10 VM to try edge that run ss13 finely.

Has to tried ie11 on win7 sorry


Return to General Chat

Who is online

Users browsing this forum: No registered users